Восстановление прошивки RB250GS и RB260GS

Автор: | 14.03.2014

Всё бы было хорошо, но по какой-то непонятной причине оборудование глючит в самый неподходящий момент. И вот такие моменты случаются с роутерами и коммутаторами Mikrotik во время прошивки. Вот и случилась такая проблема у клиента с RB260GS, оборудование заменили, но восстановить работоспособность надо.
Мануал есть в вики на mikrotik.com, и всё, вроде бы доступно, вот только кривые переводы люди ищут и пытаются читать. Оригинал здесь.
Собственно процесс восстановления прошивки довольно прост:
1) Берём любой роутер, например RB951 или RB750, разницы нет, настраиваем точно как в мануале:

/ip address
add address=192.168.88.254/24 interface=ether1
/ip pool
add name=dhcp_pool1 ranges=192.168.88.1
/ip dhcp-server
add address-pool=dhcp_pool1 bootp-support=dynamic interface=ether1 disabled=no
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.254

То же самое можно сделать и через графический интерфейс, т.е. добавить IP на интерфейсе, развернуть DHCP (сеть 192.168.88. должна быть обязательно) и, самое главное — установить галочку на bootp-support.
В графическом интерфейсе будет выглядеть всё вот так:

address
Адрес для первого интерфейса.

dhcp
Настройки DHCP-сервера

dhcpgate
И ещё настройки DCHP

2) Закачать файл с прошивкой для коммутатора в папку Files на роутере (прошивки все и всегда есть на официальном сайте, для коммутатора нужна SwitchOS. Скачать с http://www.mikrotik.com/download.

files
Закачать файл с прошивкой.

3) Развернуть на роутере TFTP:

/ip tftp
add allow=yes disabled=no ip-addresses=192.168.88.1 read-only=yes \
real-filename=swos-1.2.lzb

tftp
Настройка TFTP.

4) Подключить первый порт роутера (если настройки как в мануале) к первому порту коммутатора (коммутатор при этом включать в розетку не надо), зажать кнопку «RESET» на коммутаторе и включить питание, удерживая кнопку. Дождаться когда индикатор ACT начнёт быстро моргать, отпустить «RESET» и дождаться когда прошивка зальётся в коммутатор.

Восстановление прошивки RB250GS и RB260GS: 2 комментария

  1. Вячеслав

    А что делать если под рукой нету другого Mikrotika ? Залил в RB260GS прошивку от RB250GS . Получил кирпич. Гугл не помог.

    1. mons3x Автор записи

      тогда сделать DHCP сервер из компьютера. на нём же развернуть tftp. разве что нюансы могут быть с bootp-support, вернее каким-то её аналогом. но так-то не вижу особых проблем. но проще на самом деле зайти к какому-нибудь партнёру mikrotik и попросить оживить ваш кирпич. быстрее будет…

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *